Kawasaki Concours Forum

Concours 1400 (C14) FAQ => C-14, aka Concours-14 GTR 1400 => Engine and Controls (Fuel, Ignition, Exhaust, Sensors and the like) => Topic started by: MAN OF BLUES on May 31, 2011, 04:25:17 pm

Title: Davo's fuel pump repair--redux...
Post by: MAN OF BLUES on May 31, 2011, 04:25:17 pm
Davo's fuel pump disassembly/repair

http://gtr1000.yuku.com/topic/4046 (http://gtr1000.yuku.com/topic/4046)
Title: Re: Davo's fuel pump repair--redux...please make sticky...
Post by: VirginiaJim on May 31, 2011, 04:35:33 pm
Thanks, Rich.  I'll make it a sticky temporarily until I can set up a link from one of the other stickies.
Title: Re: Davo's fuel pump repair--redux...please make sticky...
Post by: MAN OF BLUES on May 31, 2011, 04:38:46 pm
that works....

I really had to dig to find it, hate to loose that tidbit..... ;)
Title: Re: Davo's fuel pump repair--redux...please make sticky...
Post by: tthompsr on June 01, 2011, 04:30:50 pm
Thanks MOB, was looking for this right before the crash glad it's here now.
Title: Re: Davo's fuel pump repair--redux...please make sticky...
Post by: Rowlander on July 23, 2011, 07:10:21 pm
Well, I pulled my filter because I have everything else ripped off and figured why not check it out. I am glad I did... It was black!!! There were actual chunks of crap attached and around the filter and pump. To be honest, pulling the pump and filter isn't really that bad. Cleaning the filter is. I am starting off cleaning it with wd40 since it is the only thing I have on hand and it seems to be doing the job quite well. I will be letting it sit over night and check on it tomorrow. I only have 10,000 miles and can not believe the filter was that clogged. I was attributing the jumpiness at low idle to the flies being out or the throttle cables being loose. I can't wait until next week when I get her all back together and see how she acts with a clean fuel filter!!!