Author Topic: City lights not working  (Read 1283 times)

Offline kzz1king

  • Full Member
  • ***
  • Posts: 853
  • Country: us
Re: City lights not working
« Reply #15 on: February 19, 2019, 06:37:25 pm »
 Wish I would have did this when I had most of the plastic off.
2010 CONCOURS
1974 Z-1

Online maxtog

  • Elite Member
  • ******
  • Posts: 8192
  • Country: us
  • 2011 Silver
Re: City lights not working
« Reply #16 on: February 19, 2019, 08:31:41 pm »
Wish I would have did this when I had most of the plastic off.

You don't need the plastics off.  It is just a single trap door above the front fender.  Takes only a few minutes to remove (I think it is couple of screws and a couple of plastic rivets).
Shoodaben (was Guhl) Mountain Runner ECU flash, Canyon Cages front/rear, Helibars risers, Phil's wedges, Grip Puppies, Sargent World seat-low & heated & pod, Muzzy lowering links, Soupy's stand, Nautilus air horn, Admore lightbar, Ronnie's highway pegs, front running lights, all LED, helmet locks, RAM Xgrip, Sena SMH10, Throttle Tamer, MRA X-Creen, BearingUp Shifter, PR4-GT, Scorpion EXO-T1200,etc

Offline Conrad

  • Hero Member
  • *****
  • Posts: 5779
  • Country: us
Re: City lights not working
« Reply #17 on: February 20, 2019, 07:05:12 am »
You don't need the plastics off.  It is just a single trap door above the front fender.  Takes only a few minutes to remove (I think it is couple of screws and a couple of plastic rivets).

+1
Northern Illinois   Silverdammit '08 C-14 ABS

"Don't bother me with facts, Son. I've already made up my mind." -Foghorn Leghorn

Offline kzz1king

  • Full Member
  • ***
  • Posts: 853
  • Country: us
Re: City lights not working
« Reply #18 on: February 20, 2019, 01:25:14 pm »
Thanks guys. I just had that off so it will be easy peasy!

Wayne
2010 CONCOURS
1974 Z-1