Poll

Have you ever experienced a problem with the battery, terminals, connectors, grounds, etc that caused the C14 to act strangely when trying to start or caused the bike to die after being started? (Read first post before voting)

Owned C14 less than a year- NEVER had such issue
Owned C14 2-6 years- NEVER had such issue
Owned C14 7+ years- NEVER had such issue
Owned C14 less than a year- HAD the issue
Owned C14 2-6 years- HAD the issue
Owned C14 7+ years- HAD the issue

Author Topic: Poll- unusual voltage/kipass issues  (Read 860 times)

Offline PH14

  • Full Member
  • ***
  • Posts: 1174
  • Country: 00
Re: Poll- unusual voltage/kipass issues
« Reply #15 on: July 19, 2020, 06:54:28 pm »
Only those two times.  I don't need lightening to hit me more than twice to learn something.  BTW, this does not apply to the Indian which I have washed significantly more than twice.

 :yikes: He has gone to the other side...the clean side, but the other side nonetheless.

Offline PH14

  • Full Member
  • ***
  • Posts: 1174
  • Country: 00
Re: Poll- unusual voltage/kipass issues
« Reply #16 on: July 19, 2020, 06:55:19 pm »
So, in other words, you have a KiPass problem about every two years?

 :rotflmao:

Brian

 :rotflmao:

Offline VirginiaJim

  • Administrator
  • Elite Member
  • *****
  • Posts: 10981
  • Country: england
  • I've forgotten more than I'll ever know...
    • Kawasaki 1400GTR
Re: Poll- unusual voltage/kipass issues
« Reply #17 on: July 20, 2020, 07:41:43 am »
LOL...
"LOCTITEĀ®"  The original thread locker...  #11  2020 Indian Roadmaster, ABS, Cruise control, heated grips and seats 46 Monitoring with cutting edge technology U.N.I.T is Back! 2008 C14 Moved on to a new home, 2016 RM traded in.