Author Topic: Bike is dead  (Read 199 times)

Offline courtney985

  • Newbie
  • *
  • Posts: 1
Bike is dead
« on: July 29, 2020, 01:48:54 am »
Hello all,

Been a lurker for a while, but am having a problem with my 2011 that I'm hoping to get some feedback with. Long story short, stopped for gas on the way to work and when attempting to start the bike it acted as if the battery was dead (thumbing the starter cause the instrument panel to dim and throw various errors about FI, Immobilizer and KTRC…unfortunately I noticed no error code #). It's done this before, but usually switching it off and waiting a second or two it would fire up normally. No go this time and progressively got worse the more times I retried; I believe that at this point I was just draining the battery. Eventually I got a tow and the bike is now sitting in my garage on the trickle charger.

Since I’ve had it home, the behavior has changed a bit. When it was first fully charged the dash would light up normally (both left red and oil light, dials would spin, etc), but once I hit the ignition switch I’d get nothing but a rapid clicking noise coming from the tank area and an alternating errors on the display: KTRC and K-ACT ABS error.

Strangely, since getting the battery tested (it’s good) the bike is now acting differently. Now when I turn it on the display takes a moment before illuminating and pressing the starter I hear a click and the dash goes dark with only the oil light faintly illuminated (along with Neutral). Turning off the key nob and back on repeats the same behavior.

For the record, the bike is a 2011 with  22k some odd miles (I bought two years ago in Nov with under 7000 miles) . I installed a new battery in January, and just had it load tested resulting in a healthy status. Also, all fuses appear to be intact and functional. Lastly, I performed a diode test on the Voltage Regulator/rectifier having had bad experience with failure on my last bike, a Triumph Sprint ST, but it appears sound.

Any suggestions on what might be the problem or next steps I should take in troubleshooting?  Thanks in advance!

ดูบอลออนไลน์

Offline Boomer

  • Full Member
  • ***
  • Posts: 431
  • Country: gb
  • Wickford, UK
    • Boomers GTR Site
Re: Bike is dead
« Reply #1 on: July 29, 2020, 02:39:42 am »
Check that all bolts on the battery earth cable are fully tight.
The C14 needs a solid earth connection so check both ends of the earth cable.
Loose connections and corrosion on the connections are common.
George "Boomer" Garratt
Wickford, UK


Offline B.D.F.

  • Hero Member
  • *****
  • Posts: 4820
  • Country: 00
  • It's only really cold if you fall down in it.
    • C-14 farkles you almost cannot ride without.
Re: Bike is dead
« Reply #2 on: July 29, 2020, 03:14:07 am »
Ignore any / all error codes shown as they are byproducts of the base problem, and that problem is either a bad battery or (more likely) poor contact on the battery cables. Remove the battery, then the cables and clean both the battery posts as well as the cable ends. I prefer to do this with a wire brush as that does not leave any grit behind which can cause further problems. Then check the battery cable connection to the frame; this is often corroded and a typical cause of what you are describing.

Best of luck but the above should clear up your problem.

Brian

Hello all,

Been a lurker for a while, but am having a problem with my 2011 that I'm hoping to get some feedback with. Long story short, stopped for gas on the way to work and when attempting to start the bike it acted as if the battery was dead (thumbing the starter cause the instrument panel to dim and throw various errors about FI, Immobilizer and KTRC…unfortunately I noticed no error code #). It's done this before, but usually switching it off and waiting a second or two it would fire up normally. No go this time and progressively got worse the more times I retried; I believe that at this point I was just draining the battery. Eventually I got a tow and the bike is now sitting in my garage on the trickle charger.

Since I’ve had it home, the behavior has changed a bit. When it was first fully charged the dash would light up normally (both left red and oil light, dials would spin, etc), but once I hit the ignition switch I’d get nothing but a rapid clicking noise coming from the tank area and an alternating errors on the display: KTRC and K-ACT ABS error.

Strangely, since getting the battery tested (it’s good) the bike is now acting differently. Now when I turn it on the display takes a moment before illuminating and pressing the starter I hear a click and the dash goes dark with only the oil light faintly illuminated (along with Neutral). Turning off the key nob and back on repeats the same behavior.

For the record, the bike is a 2011 with  22k some odd miles (I bought two years ago in Nov with under 7000 miles) . I installed a new battery in January, and just had it load tested resulting in a healthy status. Also, all fuses appear to be intact and functional. Lastly, I performed a diode test on the Voltage Regulator/rectifier having had bad experience with failure on my last bike, a Triumph Sprint ST, but it appears sound.

Any suggestions on what might be the problem or next steps I should take in troubleshooting?  Thanks in advance!

ดูบอลออนไลน์
Homo Sapiens Sapiens and just a tad of Neanderthal but it usually does not show....  My Private mail is blocked; it is not you, it is me, just like that dating partner said all those years ago. Please send an e-mail if you want to contact me privately.

KiPass keeping you up at night? Fuel gauge warning burning your retinas? Get unlimited peace and harmony here: www.incontrolne.com

Offline VirginiaJim

  • Administrator
  • Elite Member
  • *****
  • Posts: 10918
  • Country: england
  • I've forgotten more than I'll ever know...
    • Kawasaki 1400GTR
Re: Bike is dead
« Reply #3 on: July 29, 2020, 08:27:55 am »
Could also be a bad multiple ground connector in the wiring harness.  I've seen those cause trouble as well.
"LOCTITE®"  The original thread locker...  #11  2020 Indian Roadmaster, ABS, Cruise control, heated grips and seats 46 Monitoring with cutting edge technology U.N.I.T is Back! 2008 C14 Moved on to a new home, 2016 RM traded in.